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Notice 

Winsby Group, LLC makes no warranty of any kind with regard to this material, including, but not limited to the implied 
warranties of merchantability and fitness for a particular purpose. Winsby Group shall not be liable for errors contained 
herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material. 

©Copyright 2020-2023 Winsby Group LLC. 

This document contains proprietary information, which is protected by copyright. All rights are reserved. No part of this 
document may be photocopied, reproduced, or translated to another language without the prior written consent of 
Winsby Group, LLC. The information contained in this document is subject to change without notice. 
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Overview 

PIES has become the preferred method to exchange product data within the auto care industry. But 
many companies maintain product data in systems or data structures that are not PIES-aware. 
PIESExpress is a PIES publishing solution for companies that cannot otherwise deliver their data in the 
PIES xml format. 

Installation 

The setup program is a Windows Installer package stored in a zip file and downloaded from the 
PIESExpress product page of our website (the trial version becomes licensed when registered). The 
installer is digitally signed and should not be used if "Unknown" or has a signer other than "Winsby 
Group LLC". Two installers are provided, (one for Windows 32bit and another for Windows 64bit OS 
platforms).: 

PIESExpress_Setup_x86_v1.0.0.msi 
PIESExpress_Setup_x64_v1.0.0.msi 

The End User License Agreement is displayed during installation. By using the software, you agree to 
the terms and conditions of that Agreement. 

Running the setup program installs two shortcuts on your desktop, one for PIESExpress and a second 
for this user manual. A shortcut to “PIESExpress Samples” is created in your Documents folder and 
contains sample projects from various data sources. 

NOTE: PIESExpress requires an Access Database Driver. if you don't have MS Office installed, or if you 
do have Office installed, but it is O365 you will need to install it. 

Download the proper Microsoft Access Database Engine 2010 Redistributable from the link provided 
below. Use AccessDatabaseEngine.exe for x86 setups or AcessDatabaseEngine_X64.exe for x64 setups. 

http://www.microsoft.com/en-us/download/details.aspx?id=13255 

Software Registration 

The program will run in a limited “Trial” mode until it is registered. When you purchase a license, you 
will receive two pieces of information via email such as. 

ACME Automotive 
9d91d202-6ce8086c-fc571dc2-3c40ff9a 
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Start PIESExpress and use the Help > Register menu to bring up a dialog screen. Copy and paste the 
two lines exactly as they are delivered in the email. Press OK to complete the registration process. 

AutoCare PCdb 

PIES reference codes are provided by AutoCare in the PCdb (Part Category Database) and are required 
for the program to function properly. 

This database is updated monthly and is available for free from AutocareVIP (after registering) in 
several formats. It is a good idea to create a local directory where the latest version is stored and can 
be accessed by the program (using the MS Access .accdb version). 

Launching PIESExpress 

Double-click on the PIESExpress shortcut icon on your desktop to start the program. Alternatively, you 
can double-click on any .piesexpress file and it will start the program and load that project (just as 
you might with a Word or Excel document). 

Missing Source Data File 

If you attempt to open a project where a “source” file (explained below) is not located on your system 
or network, the program will provide a warning and display the standard File Open dialog so you can 
locate the missing file. 

One way to keep this message from occurring is to work under the “Project folder” as defined in the 
options screen: 

 

All source files are relative to this folder, and moving a project to another machine is as simple as 
placing it in their defined “project folder”. 
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Main Screen 

When you first start the program, you will see the following screen.  

 

The main screen is divided into four areas: (1) Title bar, (2) Menu bar (with associated short-cut 
toolbar), (3) Current project (or blank as shown above because nothing is open yet), and (4) Status bar. 
The Title bar shows the program name followed by the currently open project name (if any). The Menu 
bar includes a “File” menu and “Help” menu.  

File Menu. The first “section” of the File menu provides ways to manage your projects. Each 

PIESExpress project is a separate file on disk with a “.piesexpress” extension. Menu items are 
provided to create a new project, open an existing project and save the project (optionally with a new 
name). 

TIP: It’s recommended that you create a new directory for each project you work on, along with sub-
directories for your data sources and output files. 

Open PCdb. Use this selection to link to a saved PCdb (MS Access database). The location is 

remembered so you don’t need to open it each time you start the program, but it can be changed at 
any time. When opened, the “version” is shown in the status bar at the bottom of the screen. 

¡ 
¢ 

£ 

¤ 
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Program Settings (Options). There are currently two user settings available on the Options 

screen: The “Project Folder” and program “Appearance”. The project folder defines where to find the 
project definition files you use to control the PIES publishing functions. 

The Current Project 

When you open a project (or create a new one), the main section in the screen will change to show 
the Project Tree on the left and associated settings for the selected item in the tree on the right. If you 
press the New Project button, for example, you’ll see this: 

 

The area on the right relates to the selected root in the project tree with general project settings. 
Changing the “Project name” field on this form will show that name in the top item in the project tree. 

 

There can be, as in this case, required fields on a form. If you navigate to a different element in the 
project tree, it will make sure all required fields have been entered. If any problems are found, a 
message dialog box is shown, and an indicator placed next to the problem field. You can hover your 
cursor over the indicator to see more about the problem.  



P I E S E X P R E S S  
 
 

 

5 

 

For example: 

 

In the project tree shown above, the General Segments and Item Segments (expanded here to show 
default contents) corespond to PIES “segments” as defined in the PIES Standard. General Segments 
refer to non-item specific segments such as Header, Market Copy and Price Sheets; while Item 
Segments refer to item-specific segments such as Item, EXPI, Attributes, etc. Double-click on a 
container in the project tree to expand it. 

Sources. Each project requires at least one data source. This could be an Access Database (.accdb), 

an Excel file (.xlsx), a comma-separated-values file (.csv), or a delimited-text file (.txt). 

To add a new data source, click on “Sources” in the project tree and right-click to show the “Add” 
option. Give the source an internal name (e.g. “Main”) and select the Filename. A standard Windows 
File Open dialog is displayed. Use the “Files of type” drop-down to select the type you need: 

 

If the file type is not Access, you will probably have a file with column headings. If this is the case, 
check the “Has field names” option to tell the program to use the first row as column headings. 

If you select a delimited text file (that is not tabbed-delimited) you will need to fill in some other 
information as shown here: 

 

You can add as many Sources as required, provided they have a related column in common (so they 
can be joined together). This is normally done with a Part Number column in each source file. 

It is a good idea to press the “Test Connection” button after selecting the file to make certain it is 
accessible by the program. 

TIP: Save your work periodically using File > Save or the “Save” button on the toolbar. 
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Source Links. If you have more than one Source defined or a Source contains more than one table 

or worksheet that you need, you must define how they will be linked together. 

To create a new Source Link, right click on Source Links in the project tree and press Add. 

Create a Name that describes the relationship. For example, “Item_Description” for a relationship that 
links the Item table with the Description table. 

 

This describes a relationship between two tables in an Access (or Excel) file. The Table for an Excel file 
refers to a worksheet. 

Press the Plus button to add a link field. Here (as in most cases) they refer to a common Part Number 
column in both the Item and Description tables. 

General Segments. As mentioned above, the General Segments container is used for PIES 

segments that are not driven by the Item (Part Number). 

Header. The header segment is required, but does not necessarily require an external source. The 

only elements that you must supply are PIES Version, Brand Owner DUNS (or Brand Owner GLN), and 
PCdb Version Date. 

These requirements are displayed on the details page when you select the Header item in the project 
tree. In fact, all mapping tables are structured (and maintained) similarly. Let’s discuss that first. 
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Item Segments. The “Item” segments manage mapping for all PIES segments driven by part 

number. “Item” is required and so automatically added. 

To add additional item segments, right-click on the “Item Segments” container and press the “Add 
segment” button (note: you must have a Source defined first): 

  

Then select the desired segment you want to add (such as “Description”). There are a few segments 
which depend on other segments being defined first. You can see above that “Digital asset 
descriptions” cannot be added before the “Digital asset” segment. 

To remove a segment (except for the required Header and Item segments), right-click and press Delete. 

Once a segment has been added, you will be presented with that segment’s mapping screen. 

Mapping Screens 

The main job of PIESExpress is to “map” your source data to PIES terminology.  

Each mapping screen looks similar. Each will have a section at the top with section title and two drop-
downs to define the data to be mapped: 

 

Here is an example of the Header mapping screen when it’s first displayed (before any maintenance 
has been performed). 
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The Source drop-down is populated from defined Sources. The Table drop-down is populated from 
available source tables (or Excel sheets and named-ranges). Excel sheets will have a “$” suffix. 

The Elements grid displays all PIES elements that could be mapped to the source columns (or provided 
with a “default” value). This grid contains four columns: Code relates to the PIES specification, Element 
is the PIES element name, Req defines that element’s requirement setting (M = Mandatory, O = 
Optional, C = Conditionally required if another field is not included, K = Mandatory or optional Key 
field). Hover your cursor over a “C” type to show the other related field. For example: 

 

The final (right-most) column in the Elements grid does not have a header, but indicates whether or 
not the PIES element has been mapped (either to a source data column or with a default value). A “D” 
indicates a standard data mapping. A “P” indicates a mapping that requires parameters (described 
further below). 
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Default Values. A value entered or selected in the Default combo-box will apply if there is no mapping 
defined for an Element, or if a mapping is defined, but the source column has “no data” as defined on 
the main project page: 

 

Here is an example of a Default value being supplied for a Mandatory PIES element without mapping 
to a data source column. This means that A03 will always have “UPDATE”: 

 

Some PIES Elements have a “list of values” defined which are then used to populate the Default drop-
down, as shown here for A35 “Currency”: 

 

AutoMap Button. Each mapping screen has an “AutoMap” button above the Elements grid. This is 
designed for the simple case where your source data columns match the PIES element names exactly. 
Pressing this button will create a “Maps To” column entry for columns that match. 

Mapping Elements (D). To map a column in the source table to an element in PIES, select the desired 
PIES element and then press the plus (+) button in the Maps to area. Pressing the plus button creates 
a new blank row in the column list. Selecting the blank row loads a drop-down list of available columns 
from the selected Table for you to complete the mapping. 
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Typing in the column list starts a quick search within the list. For example, the following shows the 
drop-down after typing “it”: 

 

This search is not a “Filter” but simply positions you to the first column name that matches what you 
entered. (A pause in typing will reset the search. So “i” [pause] “t” will position at the first column 
starting with a “t”.) 

Parameter-Based Map (P). There are cases when a column in your source table needs more informa-
tion to complete the map. For example, your data may include two Product Description columns, such 
as: 

 

The “Descriptions” mapping screen looks like the following. Notice that the source data above does 
not include a “Description Code” (C05), and it is a required Key. 
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The way to handle this is to map each of the source description columns (“short” and “invoice”) to the 
Description (C10) element. You now have two columns in the Maps to list (as seen above). But we 
need more information to tell the system how to code these two columns’ values. This is accomplished 
using the Parameters grid. 

We selected the first source Column (“Product Description - Short - 20” in this case) and then clicked 
in the Description Code Parameter Value. It showed all of the Description Codes as defined in PIES: 

 

It was then a simple matter to match the code to the type of description that is being supplied. In this 
case (SHO). 

Note that we did not map anything directly for the C05 Description Code Element. PIESExpress 
generates the proper PIES xml with the required Description Code automatically. That is why it shows 
that the value is supplied by the Parameters (as indicated by a “P”). 

One way to remember that you probably need a parameter is if a key value (“K”) element is not 
included in your source data as a separate column. This often happens when you have de-normalized 
(i.e., “flattened”) data with repeating columns instead of normalized data with repeating rows. You 
often see this in wide Excel sheets where you have multiple prices or multiple packaging levels for one 
part number. 

Here is a similar example for Extended Information (EXPI) since it is often handled as one row of fields: 
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Note also that the Parameters grid changes depending on the Segment. Here is an example of the 
Packages segment. Notice that several Elements depend on Package UOM (H15) and that you might 
need to also supply a “Quantity of Eaches” as a parameter (e.g. “1” for the “Each Package Level”). 
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In this case, you also need more than one parameter assisted map. The “Quantity of Eaches (H20)”, 
looks like this: 

 

 

 

Notice we didn’t need to enter a “Quantity of Eaches” parameter in the second or third case. 
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User-Defined Lookup Columns 

When source data is not stored exactly as needed by the PIES standard, you can create a “Lookup” 
column to change it. The concept is similar to Excel’s VLOOKUP feature in that you can define a source 
column as a key to a lookup table, and substitute another value from that table which matches the 
key. 

 

The “Source” column in the Value Map (lookup table) is populated from the Lookup Value column of 
the source table. 

There are two ways to fill in the Map To column of the Value Map: (1) Enter text values, or (2) Pull 
actual PIES codes from the PCdb. The example above shows this second approach. Using this method 
will probably be the most common choice because it ensures the correct codes are used. 

If the PIES Code “Element” is set to “EXPI Data”, the EXPI Code dropdown is populated for selection. 

We recommend using a leading underscore for user-defined lookup column names to distinguish them 
from actual data source columns. You then use that name in the other mapping screens just as you 
would normal source data columns. 

Publishing PIES 

Once all of the mappings are completed, press the “Create PIES XML” button to generate the PIES file. 
A standard Windows Save Dialog screen will let you create the file (with a default name provided). 
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A list of errors (if any) will be presented in a grid for your review: 

 

It is important to note that data validation errors (such as these) do not keep the program from 
producing PIES output for any reported elements. 

 

 


